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1. Introduction
Since the last Kosmo Desktop 2.0.1 version from the past July, 7th 2011 until today, the Kosmo - The Free SIG
Corporative Platform has been evolving internally until its current state.
We expect to start a new version publishing politic from this new Kosmo Desktop 3.0 version, so they'll be more
usual than the previous stages.
As any other area, any collaboration in upgrading and/or translating the new information into any language
(application, user guides, videos, ...) would be welcomed.
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2. New version changes
We want to hightlight the most important changes applied to the new Kosmo Desktop 3.0 version. As a
summary, the number of new functionalities / improvements / bux fixes added to it is very large and they won't
be detailed.
We're currently working on updating all the existent user guides and videos, as well as generate new user
guides and videos that will explain all the new functionalities and improvements present at the new version. We'll
publish them as soon as they'd be available.

2.1. New features
2.1.1. Generic
Languages
Updated the next languages to the new version:
English
Spanish
Finnish - Jukka Rahkonen
Catalan - Laura Olivas - Servei de Sistemes d'Informació Geogràfica i Teledetecció - UdG ( http://www.sig
te.udg.edu)
Croatian - IGEA (http://www.igea.hr)
Italian - Giuseppe Aruta

New extensions
A new set of extensions have been added to the new version. They are detailed next:
Massive import/export operations
Wizard for processing massive data import / export operations: from a directory / database to a directory /
database / unique file. It allows also to apply reprojections to the source data, as well as a sort of
configurable options. It's much more than a simple import/export, because it allows massive reprojection
processes, generate a continuous layer from multiple datasources, ...
Hierarchical finder
Extension that enables the "Hierarchical finder" tool, that allows to configure a locator using the layer
fields. E.g.: it's possible to locate a plot by its fields province, municipality, polygon, ... It's a simple but
powerfull searching mechanism totally configurable for any work, and that helps by saving a lot of time.
Edition by using domains
Extension that allows to configure the valid values for a layer fields and the rules associated to them.
There is also a navigation / edition interface available that uses the configured domains. This extension is
much more that a simple domain definition, because it allows to generate forms dinamically in order to
edit the information, based on those domains. It makes editable features navigation and visualization
easier.
Export view to PDF
It allows to export the current view to PDF, using the parameters configured by the user (paper size,
scale, ...). It also allows to generate batch processing outputs, from a input frames layer.
Tools for working with the Spanish Cadastral Virtual Office
Set of tools that uses the public web services offered by the Spanish Cadastral Virtual Office: plot
localization by cadastral reference, information about the cadastral references present at a clicked point,
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...

Java Virtual Machine and libraries
Java Virtual Machine: Updated to the 1.6.0_37 version.
JTS: Updated to 1.13 version.

2.1.2. Datasources
Generic
Improved 3d data support: when loading / saving data Z coordinate is taken into account.

Raster
Kosmo Desktop raster libraries have been updated, so the set of raster supported formats have been increased.

Databases
Added support for multiple geometry fields layers, in loading and saving mode.

PostgreSQL / PostGIS
Improved support for PostgreSQL 9.X and PostGIS 2.0: it's not necessary to load legacy.sql file in order to
access to the database.

Oracle
The DBF that allows to convert between Oracle internal SRS codes and EPSG codes have been moved outside
the jar file to the application directory /bin/resources/dao/oracle de la aplicación, so the user can modify it to
adapt the file to his needs.

DXF
The DXF driver have been completely reworked almost from scratch, both loading and saving: the memory
consumption has been decreased and the loading speed have been highly improved; the writer have been
completely rewritten, adding a new set of options to it.

OGC Services - WMS
The WMS services support have been improved in the new Kosmo Desktop version:
User can define a set of XML files with all the WMS servers he wants to access to. By default Kosmo
Desktop ships a set of them and we'll increasing / updating them through new downloads at the project
web. If you like to share a server set for a geographic region and / or thematic area, just send it to us and
we'll publish, or send directly to the Kosmo mailing list.
Service version selection: added the possibility to set the WMS service version to use to connect to the
server.
WMS 1.3.0 version support: the new WMS standard version 1.3.0 redefines, among other modifications,
the axis order for a set of spatial reference systems. Kosmo Desktop takes into account the axis order
when it does the WMS requests, as well as it offers an option to ignore this behaviour if the server the
user wants to connecto to doesn't take into account the new axis order.
Basic HTTP authentification: added the possibility to define a pair user/password to those WMS
services that need them.
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Feature info: added the possibility to set the number of features to retrieve in a feature info request
(default, 1).
Vendor parameters: added the possibility to stablish a set of optional parameters to connect to the server.

OGC Services - WFS
The WFS services support have been improved in the new Kosmo Desktop version:
User can define a set of XML files with all the WFS servers he wants to access to. By default Kosmo
Desktop ships a set of them and we'll increasing / updating them through new downloads at the project
web. If you like to share a server set for a geographic region and / or thematic area, just send it to us and
we'll publish, or send directly to the Kosmo mailing list.
Service version selection: added the possibility to set the WFS service version to use to connect to the
server.
Transactional edition: added the possibility to edit transactional WFS layers for 1.0.0 and 1.1.0 versions.
When editing a WFS layer, all the generic tools are available, the same as any layer. The layer tree
shows a different icon to show if a WFS layer is (or isn't) a transactional layer.
Basic HTTP authentification: added the possibility to define a pair user/password to those WFS
services that need them.
WFS 1.1.0 - Check results: added a new button to the last wizard step to check the number of features
that will be retrieved for each layer using the filters configured before loading it.

2.1.3. Symbology
This is one of the most improved areas in this new Kosmo Desktop version: a new set of options have been
added to the symbology. The most important ones are the next::
Gradient: added the possibility to define color gradients for symbol fills.
Labelling - new options
Follow line: force the label to follow completelly the line which it's assigned to.
Repeat labels: repeat the label each X pixels.
Automatic line break: force the label to insert a line break when it reaches a specific size or it finds
a '\n' character.
Minimum label distance: set a minimum distance between each label to avoid label collisions .
Maximum label displacement: in the new labelling engine, if a label can't be placed in its calculated
anchor point by any reason (it goes outside the screen, there is another label there, ...) the engine
will try to place it moving first the label position related to its anchor point. If it can't place it either,
this option will allow to increase the new position search radius in order to let the label appear.
Force left to right read: when a lineal feature is labelled, when the label follows it, it can be read in
the opposite direction. This option allows to change the label rotation so it can be read right. This
option was already present by default in the previous version, but in this new one the user can
enable /disable it from the GUI.
Graphic background: this option allows to set a graphic background to the label, increasing its
visibility. Any available graphic can be used (marks or images).
Decorators: the existent basic style decorators have been evolved so they are completely configurable, as
well as a new set of decorators have been added (only present at the advanced style editor).
Units of meassure: it's possible to define the symbol size, apart from screen pixels, as in the previous
versions, in real units (mm, cm, m, km, miles, feets, ...). The symbol will modify its size depending on the
current map scale if a real unit is used. This option is available for point symbols, line widths and
decorators.
Line width: it's possible to define the line width by using a fixed value or from the layer attribute values. .

2.1.4. Spatial Reference Systems
Added the possibility to define custom user SRSs.
Added the next SRS definitions into the EPSG database shipped with Kosmo Desktop:
EPSG:3763 - ETRS89 / Portugal TM06.

@ 2013 Sistemas Abiertos de Información Geográfica, S.L.

Kosmo Desktop - Version 3.0 RC1 changes (EN) | 8

EPSG:3765 - HTRS96 / Croatia TM.
EPSG:900913 - Google Maps projection.
EPSG:3785.
EPSG:3857.
IGN grid files shipped with Kosmo Desktop have been updated to the latest available version.

2.1.5. Topology rules
Added a new topology rule "No gaps between areas" that allows to check that there aren't gaps for a
continuous polygonal layer.

2.1.6. Tools
Generic
In order to reduce the memory usage when executing some tools, a new results generation architecture
through a progressive feature iterator have been generated, so the results are being generated and saved
"on the fly". This new architecture have been applied to the next tool set (in the next versions it will be
applied to more tools):
Tools > Calculate > Generate polygon network.
Tools > Conversion > Convert table to layer.
Tools > Conversion > Extract First and Last line vertexes.
Tools > Conversion > Extract segments.
Tools > Conversion > Get points from lines.
Tools > Conversion > New affine transformation.
Tools > Utils > Export reprojected layer.
Tools > Utils > Detect duplicated features.
Tools > Utils > Remove duplicated features.

Category visibility button
A new button has been added to the scale panel that allows to configure the visibility for all the categories for the
current view. The available options are the next:
Expand all the categories.
Collapse all the categories.
Category visibility (show/hide all the layers from the given category).

Configure filter (Layer menu > Advanced configuration > Configure filter)
Added a new tool that allows the user to set up a filter for a database layer, so only the features that accomplish
the given filter would be loaded into the layer.

Stablish layer style (Layer menu > Symbology > Select the default layer style...)
Added a new tool that allows to set up the default layer style in a fastest way (if the layer has more than one
feature type style configured).

View/Edit fields
Added the new data type "Date and time" to the set of available layer field data types.
It's allowed to modify the schema associated to a database layer (if the user has the correct rights to do
it).

View/Edit attributes
Added the buttons "Discard changes" and "Save changes" to the toolbar in order to make easier the
feature edition.
Added a specific date and date/time editor for those types of attributes.
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Access to Kosmo Desktop user guides and video tutorials
Added two new tools to Help main menu to access to the user guides and video tutorials sections from the
project Kosmo web page.

Assign by proximity (Tools > Topologic)
Added a new tool that alllows to assign a set of attributes to a target layer using as source a given layer and a
crossing layer.

2.2. Improvements
2.2.1. Generic
Extensions
The next extensions have been improved:
Sextante
The Sextante library has been updated to its 1.0 official version.
CAD tools
Added a new set of tools to this extension: Draw cuadratic Bezier curve, Draw auxiliary paralell line, Put
vertexes in crossing lines, Expand lines until crossing, Clone feature.
OpenOffice printing
The OpenOffice printing extension have improved in the next way:
Frames management: added new tools.
Batch processing: added the possibility to define a fixed printing scale set, as well as an
overlapping percent.
Printing resolution has been doubled for paper sizes up to A2 (for bigger paper sizes the resolution
have been kept).
Advanced tools
Added 3 new tools, inside the Tools > Utils menu:
Remove duplicated features: tool that allows to delete all the features with the same geometry from
a given layer.
Detect duplicated feautres: the same as the above tools, but it only detects the duplicated features,
it doesn't delete them.
Replace symbology paths: tool that allows to replace automatically all the path used in a layer
symbology for a new one.

User interface
Some application dialogs have been reworked to adjust them to smaller screen sizes.
File choosers - Locale: the file chooser language localization have been improved, so it uses the Kosmo
Desktop configured locale, not the host OS language.
Application translatable elements (layer names, category names, view names, ...) behaviour has been
improved, so the translated name appears in the Kosmo Desktop dialogs instead of the internal one.

Configuration
The default SRS for new views will be EPSG:4326 instead of EPSG:23030.
Tools > Hyperlink: added a new option that allows to configure a default relative path for hiperlinks.
Tools > Zoom: added a new option to configure the zoom factor to apply (by default, 2).
Advanced > Datasources > Shape files: added a new option to configure the default behaviour for shape
file loading.
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2.2.2. Datasources
Generic
Log file messages have been added to show the format to load and the file path (if it's a file)
In general, resource management for all the datasource has been improved, so when a layer is removed
from a project, the resources are freed in a right way (open files, memory, ...).

SHP
Language code support have been improved when loading / saving shape files.
Added a new option "Optimize memory resources" so the memory consumption when loading a shapefile
is reduced (but also the layer performance).
Added a new option to save the key field when saving a layer as a shapefile.

Databases
Added a new option to force a conversion to multigeometry when exporting a layer to a database.
Added a new option to force the field names to lowercase when exporting a layer to a database.
Added a new option to set the target geometry field name when exporting a layer to a database.

OGC Services - WMS
The default WMS server lists shipped with Kosmo Desktop have been updated.

Servicios OGC - WFS
The default WFS server lists shipped with Kosmo Desktop have been updated.
Empty WFS layers are allowed (in previous versions Kosmo Desktop showed an error message in this
case).

2.2.3. Symbology
Advanced style editor: some GUI components have been modified and redistributed to make it easier to
use it.
Dashed line styles: in this new version they have been improved, so they're really usefull .
Labelling – Fonts: the font selection combobox shows a text example for each selectable font .
Labelling – Anchor point: anchor point selection components have been modified to show a text
description instead of a numeric value.
Graphic backgrounds: the graphic backgrounds have been improved for this new version, so they're really
usefull.
Point symbols > Marks: the mark type selection combobox shows an example of each mark to make its
selection easier.

2.2.4. Edition
Added a new set of snaps: Perpendicular, Relative angles, Absolute angles, Tanget, Intersection.
The snap indicator behaviour has been improved to facilitate its visibility to the user
Added a new option that allows to visualize and edit the angle and distance for each segment when
drawing lines or polygons.
Edition toolbar: added a new set of tools to the edition toolbarn:
Copy selected feature geometry to the clipboard.
Paste geometry from the clipboard to the selected feature.
Copy attributes from the clicked feature.
Remove section in line.
Discard changes-> it allows to revert a layer to its original state, removing all the changes done
during the current edition session.
Map contextual menu: added a new set of tools to the map contextual menu:
Redraw last removed point.
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Reverse trace.
Close trace.

2.2.5. Tools
Edit > Add
Added the possibility to define a layer geometry type as multigeometry (multipoint, multiline,
multipolygon).
Added the possibility to define a layer as 3D (with Z coordinate).

2.3. Bug fixes
2.3.1. Generic
Attribute visibility
Bug fixed: non visible attributes were visible in forms and dialogs.

2.3.2. Extensions
Impresión en OpenOffice
Bug fixed: when a project with some views was printed in two differente templates, the second one
showed the first overlapped.

2.3.3. Symbology
Advanced style editor
Bug fixed: dashed line styles were not correctly loaded when they were reloaded in the advanced style
editor.

DXF - Labelling
Bug fixed: DXF layer labels were not rotated nor positioned correctly.

Filters for decimal type fields
Bug fixed: When saving a project that had filters for decimal type fields, they we're not saved correctly.

2.3.4. Spatial reference systems
Bug fixed: Grid file transformations may have wrong results because the grid files were not loaded
correctly.

2.3.5. Topology rules
Bug fixed: Memory layers don't check its topology rules.

2.3.6. Tools
Project manager
Bug fixed: when creating a new view, default user settings were not applied (spatial reference system,
view meassure units, ...).

Query wizard
Bug fixed: some wizard buttons are activated when they shouldn't.
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Save layer as
Bug fixed: when saving twice the same layer, the file chooser didn't check correctly if an existent file was
overwritten.
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